"Password Invalid" on Windows 7


#1

I’m installing Codebook for a new user at my company, who is taking over for a person who left. On a Windows 7 machine, patched to the latest, I deleted strip.db, and set a master password, putting a couple entries in. I tested locking and unlocking a couple of times.

The next morning, I tried accessing, but kept getting “invalid password”. I tried variious variations of the password, and copypasting from Notepad to make sure I was doing it correctly. No luck.

Then I re-deleted strip.db, set it up again, and tried again. Same problem. It accepts the password and its confirmation repeat, but will not accept it again, even after multiple retries.

What can I do about this.


#2

Hi @rickcogley - I’m very sorry to hear about the issue. We’ve never experienced this problem, or had another user report the same issue before, so I’d like to collect some additional information:

  1. Are you using any special characters in the password when you set it up?
  2. After running Codebook and logging in the first time if you lock the application (under File -> Lock application), but do not exit it, are you able to log in again?
  3. When you open the folder %APPDATA%\Zetetic LLC\Strip folder, what is the expanded path in file explorer?
  4. After running Codebook, could you share with us file names in the %APPDATA%\Zetetic LLC\Strip folder (e.g. does it contain both the strip.db and settings.db files, are there any other files for instance ending in -journal present there)?

#3

Hi @sjlombardo, I’ll check those things when I get to the office.

Come to think of it, we had a “weird” situation like this before, when one computer got infected by a virus and we reformatted, then restored. The strip.db backup we had on Google Drive would not accept any variant of the password, no matter what we tried. It had been working fine up until then.

These Windows systems are Japanese Windows 7 by the way, and we are using Japanese keyboards. Should that make a difference?

Iirc, the paths sometimes have Japanese in them, but I will echo that variable you ask about to see for sure.

Any of that ring a bell?

Kind regards
Rick


#4

By the way, might this be related? :


#5

And regarding the password, it was using:

  • Numbers
  • Symbols = and -
  • Letters both upper and lowercase

On a Japanese keyboard the numbers and letters are in the expected places, but some symbols (e.g. @ and single and double quotes) are shifted a bit, if that makes any difference. Hyphen and equals are on the same key, to the right of 0, with = being shift-hyphen.


#6

This is not the laptop keyboard, but, you can get the idea:


#7

Ok, here are screenshots of the system:


#8

@sjlombardo, regarding:

After running Codebook and logging in the first time if you lock the application (under File -> Lock application), but do not exit it, are you able to log in again?

…, I don’t remember that specific test. I shut CB down, then reentered it, and that worked for a while. The situation is currently that I cannot unlock at all.


#9

Hi - I was going to try uninstalling and reinstalling, but I cannot find instructions for uninstall on Windows or, an uninstaller.

I tried deleting strip.db again and noticed:

After I shut down Codebook and try to delete strip.db and/or, its parent Zetetic LLC directory, that stuff just gets recreated.

Please advise how I can delete so I can retry.

Thanks


#10

Hi @rickcogley

You can uninstall Codebook for Windows from the Add/Remove Programs window within Windows. Uninstalling Codebook for Windows will however leave the data in place; this is what allows updates via new installations to not impact your data. In order to remove the data itself, please delete the following directory:

%APPDATA%\Zetetic LLC\Strip

#11

Hi @rickcogley

We have tested this locally on a Windows 7 machine and have not been able to reproduce the behavior you describe. A couple of thoughts come to mind:

  1. Would you try performing this with an alternative keyboard, to rule out a hardware issue?
  2. Do you have more than one language enabled within Windows? If so, can you confirm that you are using the same language when initially setting the password as when you are attempting to login later? I have inadvertently pressed the alt + shift key on Windows and found myself typing in a different language before.

#12

Ok @developernotes, I’ll try those things next week.

Japanese automatically installs with English iirc, so I will definitely make sure I’m not trying to enter Japanese into the box.


#13

Ok, FYI - I uninstalled in Add/Remove Programs, deleted the Zetetic LLC directory, reinstalled, and everything seems to be working. I was able to lock and unlock, and also shut down and restart successfully, getting into Codebook each time.

I did notice the little indicator in the tray, as to what language it is switched into, and kept it on the English A.

I also noticed that I did not delete everything when I tried deleting before. I have a feeling that that had an impact on my perception. My apologies for that.


#14

Hi @rickcogley

Thank you for the follow up, we are happy to hear everything is working well for you!