Sync from iOS with Google Drive gets 404 error

I use my iPhone to sync with my Macbook over WiFi and with Google Drive so my PC and other non-wireless devices can sync. My usual method of syncing after updating entries is to a) switch to Desktop WiFi sync b) Sync with my Macbook c) switch to Google Drive sync d) Sync with Google Drive c) Sync other devices. This has worked for me the past several years.
Today I went to sync using this method and the Wifi sync went fine, but the Google Drive sync did not finish with an error ‘The operation couldn’t be completed. ( error 404.)’
I validated that Google Drive was up to date on the iPhone, did a sync with my PC to verify that the sync with Drive worked for that device, then unlinked my account from Codebook and readded it again to verify the account worked. I still get the above error.
Can anyone help with why I am now getting this error and a method to fix it?

1 Like

Interesting, but I just got the same error when sync’ing to Google Drive from my Macbook - "The operation couldn’t be completed. ( error 404.)
I’ve been sync’ing like this for years. Any ideas Zetetic?

and I just got the same error now running the sync from my iPhone

My wife and I both got the 404 error on iphones. Now, I can even use it on my Mac. Immediately closes.

It’s happening across my iOS devices (iPad and iPhone 13’s)
as well. V 4.5.10(1095)

Windows v syncs just fine, but the iOS versions fail with this
“The operation couldn’t be completed ( error 404.)”

FYI, more info on what I tried (it failed) tried deleting app from iPhone, reinstalling and syncing . I actually renamed the metadata.db and ran sync again on windows device to get a new metadata.db. Then with the newly downloaded codebook app, went thru the set up with sync key, etc generated (Used my master sync key that was previously set up and established for this new instance of codebook on iPhone)

With a newly synced codebook saved to google drive on windows machine, I then did a sync on newly installed iPhone app version…same error is received.

Same error this morning

Connect ok if no modification but 404 if new modif

Same result on multi device

Continu great job

As another datapoint – I just successfully synced My Win 11 22H2 laptop Codebook I don’t have any IOS devices to test. Good luck.

Hello everyone,

Thanks very much for using Codebook and posting to the discussion forum, although I’m sorry to hear about the troubles with the Google Drive 404 errors when syncing.

We believe we’ve identified the issue and have a fix we’re beta testing now.

Would anyone who’s experiencing the issue please write us at (if you haven’t already) and we’ll get you setup with the beta to confirm it resolves the issue for you.


1 Like

I tested out the new beta version today from Micah and can confirm both my Mac and iPhone syncs work. Thank you Zetetic for jumping on this issue so fast and fixing it (whatever caused it). I can’t live without my Codebook aka STRIP!


Yep, just tested the beta and this fixes it for me as well.


I’ve been having this 404 error now for at least three days.

The beta update worked like a charm. It’s great to see the quick response from Micah and crew. Just gotta love those guys!


The production version of Codebook for macOS (with this fix) is available now: Codebook for macOS 4.5.11 (should propagate in the near future to the Mac App Store if you don’t see it right away). We’re still waiting on final approval for the iOS App Store release, I’ll post back here once it’s available. Thanks for your patience as we work through this issue.

1 Like

Solve with last OSX-IOS upgrade