Codebook 4 hanging on iOS

Updated my iOS version to 4 (4.0.0 build 847) today, but keeps hanging at the “Sync Setup - Setup Your Sync Key” splash screen. I can dismiss the page, and so can access Codebook. However, it does not allow me to choose whether or not I have created a Sync Key (which I have on the Windows 10 application). The soft keys (yes / no) are not functional. The ? prompt remains touch sensitive though.

Navigating to More --> Sync --> Setup Sync Key has the same problem.

Using on iPhone 8+ running iOS 13.2.3

I have the exact same problem. I have my life in this program and I can Not sync now in v4. Won’t let me create a sync key in v4

Hi @harnadem and @David_Shnitkin, there is a bug in Codebook for iOS that’s causing this problem for you both. Basically, when large text size is enabled in the Accessibility settings, a bug on this view is causing the Yes and No buttons to be un-tappable. We’re working to get a fix out right away, but in the mean time you can work around this problem:

  1. Launch the Settings app on your iPhone
  2. Tap on Accessibility > Display & Text Size > Larger Text
  3. On this view, turn the “Larger Accessibility Sizes” setting off
  4. Return to Codebook – you should now be able to set up the Sync Key and tap those buttons

Can you please let us know if this helps you both? Obviously, this is not a solution, a version without this bug should be available in the next day or so depending on Apple’s App Store review time.

Problems with iPhone XR not working with version 4 of codebook

I read some of the other posts and suggestions for workaround on iOS.
Today I updated a windows version and got QR code/word list. Sync’d ok. Updated my iPad successfully. Then tried iPhone :frowning: No luck.
when I tried to add a new device (iPhone XR) the screen displayed has untappable keys also. The “dismiss” in top right corner works, but the yes/no keys do not. I did the settings workaround with accessibility
I display turned off, but that didn’t work. I even tried a hard reset on iPhone…nope didn’t work. Any other suggestions?

I’ll reply to myself…Zetetic guys told me to make sure I slide the bar at bottom of screen on the settings/accessibility workaround (see previous posts). That did the trick and it worked fine. Probably not even an issue with younger folks who never messed with text size🤣

I updated a second iPhone where text size wasn’t changed ever and the switch was seamless. Thanks again to crew at Zetetic who are great!

Thank you for the quick response with help! I appreciate it.

Just turning the “Larger Accessibility Sizes” off did not work for me.

What did work was turning the “Larger Accessibility Sizes” button off, and also slide the text size slider bar (on bottom of screen) far to the left (to make the text much smaller). Then the Yes / No buttons worked.

My apologies folks, I should have also mentioned adjusting the slider as @gk_sync noted.

We’re sorry about the bug (the fix is on the way), but we’re really happy to see the large text feature getting so much use!

My wife can’t remember her password and with the upgrade facial recognition is not working yet. Anything she can do

Hi @David_Shnitkin sorry for being slow to respond and to hear about the loss of access. There’s not a lot we can do for a forgotten master password, without it the encrypted local database can’t be opened. If it’s definitely forgotten, the only option is to reset the installation, deleting all data. For what it’s worth, turning off the Mask switch on the login view can be helpful if you want to try entering variations on what the password might be, if for instance the new password has a typo from what was intended–there’s no limit to the number of login attempts.

Did your wife change her master password recently, by any chance, and if so, would she remember the previous one, and also have used the Sync feature?